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This tutorial shows you how to add animation controls to an existing character, 
animate the character, and edit vertex weights to adjust movement and clean up 
the animation. 

In this tutorial:

• Creating a skeleton... page 2 

• Applying Smooth Skin to bind a model to a skeleton... page 6 

• Adding IK to the character... page 7 

• Setting keys in the Set Driven Key window... page 9 

• Animating the character... page 12 

• Using 2 bone IK... page 13 

• Editing vertex weights using the Paint Skin Weights tool... page 16 

• Pruning vertex weights... page 19 
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CHARACTER ANIMATION

Creating a skeleton
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Creating a skeleton
The following steps show you how to place joints and connect them to build part of a skeleton. 
Select File > Open Scene to open characterModel1.ma. This scene helps you visualize how the 
skeleton is put together under the character.

Build the skeleton

1 Press F2 to access the Animation menu set, then click in the side view to make it the current 
view.

2 Select Skeleton > Joint Tool.

3 Hold the x key to snap to the grid, then click to place the first joint at the hip, then at the 
knee and ankle of the leg, and at the heel, ball, and toe of the foot.

4 Press Enter to complete the leg.

Before you start:

This tutorial requires Maya scene files. To download the tutorial files, please visit the 
Taste of Maya web site at www.aliaswavefront.com/tasteofmaya.

Starting Maya:

Double-click the Maya 3.0 Evaluation icon on the desktop, or from 
Start > Programs > Maya 3.0 Evaluation > Maya.

In Maya:

Once the tutorial files have been installed, you have to set the current project to access 
the Maya scene files. To set the current project from within Maya:

• Select File > Project > Set and navigate to the directory where you installed the 
Maya scene files. 

• Select the Maya_tutorial_data directory and press OK.

knee joint

ankle joint

heel joint

Start at hip joint

End at toe joint
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Creating a skeleton

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
Match the right leg geometry

1 Click in the front view to make it current.

2 Press w and click the right arrow on the Move Tool’s manipulator to constrain movement to 
the x-axis.

3 MMB-drag and move the leg to fit the geometry of the right leg.

Build the skeleton back 

1 Click in the side view to make it current and select Skeleton > Joint Tool. 

2 Place the first joint slightly above the hip joint, then continue placing joints until there are 
eight.

3 Press Enter to complete the skeleton back.

Joints placed for the back

Tips

• To see the display as shown, press 6 to enter shaded mode and select 
Shading > Shade Options > X-Ray from the current view.

• To change the joint display size, select Display > Joint Size and choose a different 
size.

Tip 

Press the Insert key to move the placement of a single joint. Press Insert again to out of this 
mode.

End joint

Start joint 1
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Creating a skeleton
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Build the right arm joints

1 Click in the top view and select Skeleton > Joint Tool.

2 Starting at the clavicle, click to place five joints as shown in the following.

Joints placed for the right arm

3 Press Enter to complete the skeleton.

Match the arm geometry

1 Press w and click the right arrow on the manipulator to constrain movement to the x-axis.

2 Select the shoulder joint.

3 Rotate and scale the shoulder joint to orient the bones correctly with the arm.

Note 

The clavicle is the joint above the shoulder closest to the spine.

Tip 

To select a joint, LMB directly on the joint or LMB-drag across the bone below it. For example, to 
select the elbow joint, LMB-drag across the forearm bone.

Tip 

Use the up and down arrow keys to move up and down a joint chain.

Start joint (clavicle)elbow joint

End joint

wrist joint

shoulder joint

1
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3
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Creating a skeleton
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Adjust the arm bones to match the arm geometry

4 Select the right clavicle joint.

5 Shift-select the joint at the base of the neck and select Edit > Parent.

Create the left arm

1 Select the right clavicle.

2 Select Skeleton > Mirror Joint ❐ to open the options window.

3 Set the Mirror Across attribute to YZ.

4 Press Mirror to create the left arm.

Mirror the arm

Parent the right leg to the back skeleton

1 Shift-select the right hip joint then the joint at the base of the back.

2 Select Edit > Parent.

3 Select the right hip and Skeleton > Mirror Joint to create the left leg. 

Select right clavicle
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Applying Smooth Skin to bind a model to a skeleton
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Applying Smooth Skin to bind a model to a skeleton
Open the characterModel2.ma file or continue from the last step.

Skin the character’s body 

1 Select the character’s body. (Do not select the feet surfaces yet. They will be bound to the 
skeleton later on.)

2 Shift-select the root joint of the skeleton. The root joint is the joint at the base of the back 
from which all the other joints branch off. When you move it, all the other joints in the 
hierarchy also move.

3 Select Skin > Bind Skin > Smooth Bind.

4 To test the bind, rotate the joints in the skeleton. Press z to undo any joint rotations you 
make to return the character to its previous pose, or use Skin > Go to BInd Pose.

Skin the feet

1 Select the joints of the right leg from the knee to the toe. Select the toe joint first, then 
Shift-select the ball joint, heel joint, ankle joint, and knee joint.

2 Shift-select the right foot geometry.

3 Select Skin > Bind Skin > Smooth Bind ❐ , and set Bind to: Selected Joints. Because the 
feet are so big, this helps to keep them from being skinned to the wrong joints.

4 Press Bind Skin.

Binding the shoe to the skeleton

5 Repeat these steps for the left foot.

Tip 

Open the Hypergraph or the Outliner to help make these selections (Window menu).

Hypergraph view
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Adding IK to the character
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Adding IK to the character
Open the characterModel3.ma file, or continue from the last step.

IK Handles let you control the motion for several joints at once. You can move one object (the IK 
Handle), and several other objects (joints) change position by rotating. Since you only need to 
control one or two IK handles to create a lot of motion, you can quickly animate a skeleton. 

Add IK to the legs and arms

1 Select Skeleton > IK Handle Tool ❐ , and set Current Solver: ikRPsolver. 

2 Click the right hip joint, then the right ankle joint to add an IK chain to the right leg. 

3 Press the y key to repeat for the left leg. Pressing y returns Maya to the last used tool. In this 
case, pressing y is the same as selecting Skeleton > IK Handle Tool.

4 Repeat for the arms by pressing the y key and clicking on a shoulder, followed by the 
corresponding wrist. 

IK chain added to the arms and legs

5 Test the IK chains by selecting an IK handle and moving it. After you stop testing, press z to 
undo any transformations you make.

Tip

It is a good idea to rename the IK handles to keep the scene organized. Select an IK handle, click 
on its heading at the top of the Channel Box, and type a new name.

IK Handles
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Adding IK to the character
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Adding IK spline to the back
Open the characterModel4.ma file or continue from the last step.

Add IK spline

1 Select the right eye, then the joint at the top of the head, and Edit > Parent.

2 Select the left eye, then the joint at the top of the head, and Edit > Parent.

3 Select Skeleton > IK Spline Handle Tool, and click the stomach joint followed by the joint at 
the base of the neck.

IK Spline added to the back

Tip 

The IK Spline is controlled by a curve. When you create the IK Spline, the curve is parented to 
the skeleton. If you select the curve and press F8 to enter component mode, you can move the 
curve’s CVs to provide more control for the back. 

Remember to press F8 when done testing to return to object mode.

1

2

Parenting the eye to the skeleton

You can test the IK Spline by selecting the

IK handle and changing the Twist value. 
8 A TASTE OF MAYA  2001, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this 
tutorial, you have agreed to the terms and conditions which can be found in the tutorial’s 
installation executable available from www.aliaswavefront.com/tasteofmaya.



CHARACTER ANIMATION

Setting keys in the Set Driven Key window
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Add an attribute to control the head

Open the characterModel5.ma file, or continue from the last step.

1 Select the root joint, then Display > Component Display > Selection Handles.

Selection handle added to the root joint

2 While the root joint is active, select Modify > Add Attribute.

3 Enter headTurn as the attribute’s name and press OK.

Maya adds an extra attribute to the root joint and displays it in the Channel Box.

Setting keys in the Set Driven Key window
The Set Driven Key lets you connect an attribute from one object to an attribute of another 
object. For example, a sphere’s translate Y could drive the scale Y of a cone. When you move the 
sphere in a defined range of values in the Y axis, the scale Y of the cone changes accordingly. 

These next few steps show you how to combine custom attributes and Set Driven Key to 
automate character controls.

Load Driver and Driven

To use the Set Driven Key window, you have to load a driver object and a driven object. Once 
loaded, you modify attributes on both driver and driven and key them using the key button.

1 Open the Set Driven Key window (Animate > Set Driven Key > Set ❐ ).

2 With the root joint still selected, press Load Driver.

3 Select the joint at the base of the neck, then the joint at the base of the head, and press Load 
Driven.

Tip 

Selection Handles take the highest priority when selecting geometry. This makes it easier to 
select the root joint.
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Set initial key for Set Driven Key

1 Click to highlight headTurn in the Driver panel. 

2 Shift-select the two Driven joints and rotateX, then press Key.

Set Driven Key window

In the Set Driven Key window:

If you click the name of a listed object (either Driver or Driven), it becomes the selected object 
and its attributes display in the Channel Box.

1 Click the Driver joint, and set Head Turn to 10 in the Channel Box.

2 Shift-select the two driven joints then rotate them about 30 degrees in X. 

You can use the Rotate tool interactively and constrain the rotation to the x-axis using the rotate 
manipulator, or you can type the value into the Channel Box.

3 Press the Key button.
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Setting keys in the Set Driven Key window

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
4 Click the Driver joint and set Head Turn to -10 in the Channel Box.

5 Shift-select the two Driven joints and rotate them about -30 degrees in X.

6 Press the Key button.

Now when you change the value of the headTurn attribute on the root joint, the rotateX changes 
on the other two joints. 

Twisting the neck with Set Driven Key and a custom attribute

If you select the root joint of the character, you can click the Head Turn attribute heading in the 
Channel Box (not the value), and using MMB in the perspective view, click-drag left or right to 
change the values interactively.

Tips 

• To test the setup, adjust the Head Turn value between -10 and 10. 

• To stop the arms from moving, keyframe the IK handles (press s to set 
keyframes), or turn Stickiness ON in the IK Handle Attributes section of the 
Attribute Editor.
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Animating the character
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Animating the character
The final version of this file is called characterModel6.ma. Open this file if you want to try to 
animate the character. 

The difference between this file and the others is that the foot is set up mostly for walking. Also, 
the IK handles have selection handles for easier selection.

The feet nodes have an added attribute called Roll. When you adjust this attribute, the foot rolls 
from heel to toe making a realistic-looking walking motion. 

The foot set to Roll when walking

Note 

This foot setup comes from the Character Animation in Maya class.

The character ready for animating
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Animating the character
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Set the foot for walking

1 Select one of the foot selection handles. Notice the extra Roll attribute for the foot in the 
Channel Box.

2 Click the word Roll in the Channel Box.

3 MMB-drag left or right in a view. A new mouse icon resembling arrows pointing left and 
right displays.

Selection handles

USING 2 BONE IK
2 Bone IK is a lightweight version of Maya’s Rotate Plane IK solver that you used in the 
previous lesson. The source code for the 2 Bone solver ships with Maya so it can be easily 
incorporated into a game or real-time application.

To use the 2 Bone solver, you have to create the node first. 

Enter the following MEL command in the Command Line or Script Editor.

createNode ik2Bsolver;

If you open the IK Handle’s Tool Settings window (Skeleton > IK Handle Tool ❐ ), the 2 Bone 
solver is now available to use.

right_foot left_foot

left_wristright_wrist

root

back
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PAINTING VERTEX WEIGHTS

This lesson focuses on the Smooth Skin functionality of the Bind Skin operation in conjunction 
with Artisan to Paint Vertex Weights on a pre-built character head model. The two processes 
work together effectively to achieve control over the resulting deformation of a head model.

Open the scene file and layers

1 Open Skinning_Start.ma. 

2 Select Options > Layer Bar.

3 RMB over HeadExt and Lights and select Visibility from the list to hide the objects pre-
assigned to these layers from view. 

Create a three joint (two boned) skeleton

1 Click to focus in the side view panel.

2 Select Skeleton -> Joint Tool.

3 Draw a three joint (two boned) skeleton from the bottom up through to the top of the head, 
as shown in the following. 

4 Rename the lowest joint base, the middle joint neck, and the top joint top.

Create a two joint (one bone) skeleton

1 As a separate skeleton, create a two joint (one bone) skeleton that runs the length of the jaw. 

2 Rename the joint near the middle of the head jaw and name the other joint chin.
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Parent joints in the Hypergraph

You will now parent the jaw joint to the neck joint. 

1 Open the Hypergraph (Window -> Hypergraph). 

2 MMB-select jaw and drag-drop it onto neck. 

Notice the new hierarchy structure in the Hypergraph. Maya also automatically generates a new 
bone between the neck and jaw joint.

Bind the head to the skeleton

At this point you are ready to bind the minionHead to the skeleton.

In this lesson, Smooth Skinning is used instead of Rigid Skinning. The major difference between the 
When Smooth Skinning, vertices can be affected by more than one joint— when Rigid Skinning, 
vertex weighting cannot be shared. 

1 Select the base joint (the root joint of the skeleton chain) and Shift-select the minionHead 
geometry.

2 Choose Skin > Bind Skin > Smooth Bind ❐  and set the following options:

• Bind to Complete Skeleton (uses the entire skeleton for the bind procedure).

• Bind Method to Closest Distance (uses relative proximity of vertices to skeleton joints 
for the bind procedure).

• Max Influence to 5 (the number of joints allowed to influence given vertices).

• Drop off Rate to 5 (the rate at which the influence of joints on vertices lessens over 
distance). 

3 Press Bind.

Tip 

You could also use Edit -> Parent to perform this operation.

Noteworthy 

Although a vertex can be affected by more than one joint, the total range of influence allowed for 
that vertex must always equal a value of one. In other words, a vertex weighting always totals to 
a value of one regardless of how many joints it is shared by. It is the specific distribution of 
vertex weighting amongst the joints that allows for different results.
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4 Click to focus in the perspective view. Press 5 to view the display in shaded mode.

5 Select the neck joint and Rotate it to test the initial results of the Bind operation. 

6 Reset the rotation values of this joint back to zero when done.

Editing vertex weights using the Paint Skin Weights tool
You are now ready to begin editing vertex weights on the bound geometry using Artisan’s Paint 
Skin Weights tool. There are two ways to achieve this—interactively, as in the steps that follow, 
or using MEL (Maya's Embedded Language).

You can do this interactively, as shown in the following steps, or you can run a script in MEL 
(Maya's Embedded Language). 

Edit weight skin weighting interactively using the Paint Skin Weights tool

1 Select the neck joint and Rotate about 30 degrees on the Z-axis, then repeat for the jaw joint.

These rotations help show how the changes in vertex weighting affect the object.

2 Select the minionHead surface and choose Skin > Edit Smooth Skin > Paint Skin Weights 
Tool ❐ . 

3 In the Tool Settings window, adjust the brush size accordingly in Radius[U] and Radius[L], 
then ensure the Value is set to 1. 

4 Operation mode should be set to Replace. This replaces all vertices painted with weighting 
values to the set Value number.

5 Select the base joint from the list displayed to create a relationship between any subsequently 
painted vertices with this base joint. 

6 Paint the lower portion of the neck surface on minionHead.

The goal is to make sure this region of the head “sticks” to the position of the neck joint only. The 
value of 1 means that any painted vertices adopt a value of one (maximum) in relation to the 
base joint which eliminates the potential of any other joint effecting these vertices.

Notice how the model’s color changes as it is painted. The affected areas become white. 
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When using the Paint Skin Weights Tool, the surface color is a visual cue indicating the 
weighting values assigned to vertices across the surface. The color displays in gray scale and 
works along a tonal range where white equals a value of 1 and black a value of 0.

7 Change the Operation mode from Replace to Smooth in the Paint Skin Weights Tool 
options window. 

The Smooth operation mode helps to avoid creating hard edges between the areas with vertices 
that have a value of 1 and those with lesser values. Paint along these areas on the lower neck 
where the value difference is noticeable so it begins to look similar to the image above.

Edit the vertices weights at the top of the head

1 From the Paint Skin Weights Tool options window, select the neck joint. 

Since this joint will be used to control most of the head’s general movements, it requires the most 
paint work to create a relationship between the majority of vertices. 

2 Reset the Operation mode back to Replace and paint the top of the head down to the upper 
lip (but not the jaw area). 

The mouth should begin to open when painting the upper portion since the vertices inherit the 
rotation applied earlier to the associated joint.
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Edit the jaw vertex weights

You can now edit the vertex weighting on the jaw of minionHead.

1 Select the jaw joint and paint around the lower lip and mouth area associating those vertices 
to the jaw joint’s movements.

2 When finished painting the skin weights for this joint, choose the Select tool and select the 
jaw joint. 

Rotate the jaw joint to see the effects of the painting process. Notice how the throat area moves 
too drastically when this joint is rotated.

3 To fix the throat area, select the minionHead surface and return to the Paint Skin Weights 
Tool options window. 

4 Select the base joint from the list, and in Smooth operation mode, paint around the Adam’s 
apple area. 

Tips

• Increase the brush size when working with larger more general areas, such as the top 
of the head, and smaller for areas that require more focused selections, such as 
around the mouth. 

• Remember to use the Smooth Operation as well as Replace when refining your 
weighting.
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Pruning vertex weights
You may find that you have a lot of joints affecting each vertex. This happens often in a game or 
real-time application. To correct this, you can prune the membership (remove influence objects).

Edit weight skin weighting using MEL

1 For a NURBS object, select the CVs for which you want to prune weights. For a polygonal 
object, select vertices.

2 In the Channel Box, search for the skinCluster heading.

3 In the Command Line, type:

skinPercent -prw <weight> <skinCluster>;

The <weight> value is considered and all influence objects with a weight value lower than this 
value are removed from the selected vertices.

Finish and test the results

1 Once finished weighting the vertices, return all joint rotational values to zero, or...

Select the base joint (root joint) and choose Skin > Go To Bind Pose returning all joints to 
the position at which they were set during the Bind Skin operation. 

2 From the Layer Bar, RMB over the HeadExt and Lights layer, and select Visibility from the 
list to see the objects pre-assigned to these layers.

3 Select Window > Hypergraph and then MMB-drag-drop minionBottomTeeth onto the jaw 
joint. 

4 Repeat the same procedure to place minionTopTeeth, minionEyes, and minionEarRings 
onto the neck joint. 

5 Select the neck joint and jaw joint to rotate and test results.

Tips 

• It may be useful to rotate the jaw and neck joints a bit more to better gage the results 
across the surface. 

• If other problem areas become noticeable, such as hard breaks along the cheek bone 
area or back of the neck, use Smooth and Replace where necessary with the 
appropriate selected joint.
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HELPFUL HINTS

The following points should help when animating the character:

• Only the following nodes need to be animated: root, back, right_wrist, left_wrist, 
right_foot and left_foot.

• Set keyframes by pressing s or select Animate > Set Key.

• Animation curves can be adjusted in the Graph Editor
(Window > Animation Editors > Graph Editor).

• When setting keys, start with the root and feet nodes to block out the animation.

• Finer animation of the arms, back and feet rolling should be secondary.

• You can get real-time playback using Window > Playblast.

CONCLUSION

You have now experienced how easy it is to prepare a character for animation in Maya. To recap, 
this tutorial showed you how to:

• Create joints and build skeletons.

• Add IK chains.

• Use IK Spline for smooth and organic control.

• Create custom attributes for finer control.

• Use Set Driven Key to create relationships between nodes which simplifies character control.

Tip 

Other animation procedures are also covered in the Part 1—Comic Book Setup, Part 2—Blended 
Comic Book, and Jellyfish tutorials.

Tip

Character setup and animation can be very complex. Alias|Wavefront offers a Character 
Animation course that explores these topics in depth. For more information go to 
www.aliaswavefront.com (Express Link to Training).
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