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This lesson focuses on Maya basics. Subsequent lessons assume you have 
sufficient knowledge about Maya’s User Interface and how to navigate the many 
windows and editors provided, as well as using such elements as tools, 
shortcuts, and marking menus. 

If you are familiar with Maya, you can skip this lesson, but it’s a good idea to 
refresh your memory from time-to-time and to check to see if any changes have 
been made to the interface since you last used the software.

In this tutorial: 

• Getting started... page 2 

• Using Maya’s primitives and camera tools... page 3  

• Using transformation tools... page 4 

• Using the Shelf and renaming objects... page 6 

• Using the Channel Box and Outliner... page 7 

• Improving the object’s display in the views... page 8 

• Selecting and transforming components... page 9 

• Positioning objects... page 10 

• Duplicating and instancing... page 11 

• Working with pivots... page 12 

• Using editors to select nodes and adjust attributes... page 13 

See also Maya’s Embedded Language (MEL)... page 16  and 
Maya UI definitions in brief... page 21 
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Getting started
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Getting started
1 Select Start > Programs > Maya 3.0 Evaluation > Maya. 

2 Scan the top left of the main window. This is where the most often-used items are located. 

• common menus (from File to Window) at the top of the main window contain items 
general to all Maya operations. 

• Each menu set corresponds to a Maya software module—Animation, Modeling, Dynamics, or 
Rendering. You switch to a different menu set by selecting it from the pull-down menu. 
Menus specific to the menu set display beside the common menus.

• common tools (sometimes referred to as the “Mini Bar”) are located just below the menu 
set. You use these tools to select, move, rotate, and scale items. 

3 Choose Window > Settings/Preferences > Preferences. 

Maya provides a vast array of settings you can adjust to customize your Maya sessions. For 
instance, you may need to undo several operations as you go through these tutorials. You can 
specify the number of undo’s and save this as a preference, which means this setting is used 
every time you start Maya. 

4 From the category list on the left, click Undo (next to the bottom) and set Queue to Infinite 
(on the right). This setting lets you undo an unlimited number of previous operations using 
Edit > Undo. 

5 Click Save to save your preferences. 

Before you start:

This tutorial requires Maya scene files. To download the tutorial files, please visit the 
Taste of Maya web site at www.aliaswavefront.com/tasteofmaya.

Starting Maya:

Double-click the Maya 3.0 Evaluation icon on the desktop, or from 
Start > Programs > Maya 3.0 Evaluation > Maya.

In Maya:

Once the tutorial files have been installed, set the current project to access the Maya 
scene files. To set the current project from within Maya:

• Select File > Project > Set and navigate to the directory where you installed the 
Maya scene files. 

• Select the directory Maya_tutorial_data and press OK.

Common menus

Menu sets

Common tools (Mini Bar)
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BUILDING BASICS

This basic lesson steps you through using Maya’s primitive shapes to build a door. You will 
learn how to use Maya’s transformation tools, how to adjust the camera view using the mouse 
buttons, and how to use various editors and windows.

Using Maya’s primitives and camera tools
Maya provides NURBS and polygonal primitives. These primitive shapes—cubes, spheres, 
planes, cylinders, and toruses—can be used as a base and then manipulated using Maya tools 
into the shapes you need. The door you will learn how to build in this tutorial starts with the 
most primitive of primitives, a cube.

Create a door from a polygonal primitive cube

1 Select Create > Polygon Primitives > Cube. 

The polygonal cube displays in a view, which is a window into your 3D scene. It is also called 
the workspace, and sometimes called the camera view. 

2 Dolly in: Hold the Alt key and drag to the right while pressing both the left (LMB) and 
middle (MMB) mouse buttons.

Dollying moves a virtual camera forward (drag right) or backward (drag left). Dolly in to get a 
closer view of the cube.

3 Track down: Alt-drag-MMB. 

Tracking moves the view up, down, left, or right. Track down to be able to see the door when it’s 
finished.
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4 Tumble down: Alt-drag-LMB up. 

Tumbling revolves the virtual camera around a center of interest. It is easier to work with the 
cube when the camera view is level with it instead of looking down on it. 

5 Select Panels > Layouts > Four from the menu bar in the view. 

You can divide the workspace into multiple view panels. These four views, perspective, side, 
front, and top, are a common layout. (The top, front, and side views are called orthographic 
views.) 

Using transformation tools
The following introduces you to Maya’s transformation tools and how to transform objects 
effectively in different views.

Scale the cube

1 Click the Scale tool’s icon from the Mini Bar at the top-left of the main Maya window. 

The name of the tool and a tip display in the Help Line at the bottom of the main Maya window. 
This is one of Maya’s standard conventions.

Notes

• Dolly and track work in all these views, but tumble works in the perspective view 
only.

• These camera tools and more are available from the View > Camera Tools menu in 
each view.

• To focus on just one view, click in the view, let go of the mouse, and press the space 
bar. To return to a four panel view, press the space bar again.
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Using transformation tools
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2 In the front view, click the top square of the Scale tool’s handle. If a handle does not display, 
click the cube. 

Maya’s transformation tools have manipulator handles corresponding to the XYZ axes. The 
handles control the direction of the transformation. Clicking a handle isolates the transformation 
to that direction.

3 Drag the top handle up until the top of the cube reaches the first grid line above ground 
plane. 

The ground plane is the XZ plane—assuming Y is the up axis—and displays as a dark horizontal 
line in the front view, and as a grid in the perspective view.

4 Click the center handle and drag right until the top of the cube reaches the third grid line. 
Dragging the center handle scales in all directions. This maintains the proportions you 
created in the previous step.

5 In the top view, click the lower handle and drag up until the cube’s thickness is that of a 
door (look in the perspective view). 

6 Click the Move tool icon. The manipulator handles change according to the transformation 
tool you select. If you’re ever unsure which tool you selected, the handles can give you a 
good visual cue.

Tip 

Drag, but don’t click, the mouse over an icon to find out what tool it represents.

Scale handle

Drag the center handle to
scale in all directions.
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7 In the front view, drag the cube up until the bottom is on the ground plane. You now have 
a basic door. 

Using the Shelf and renaming objects
This portion of the tutorial uses a NURBS sphere primitive and the scale tool to create a 
doorknob. 

Create a basic doorknob

1 Click the sphere icon in the Shelf to create a NURBS sphere. 

Maya’s Shelf provides quick access to any Maya operation. Since you can also customize it, you 
can organize commonly used actions and tools into groups, such as modeling, animating, and 
rendering. 

The sphere you created is based on the NURBS modeling system (Non-Uniform Rational 
BSpline). You can also create Maya’s other modeling surfaces, polygons (such as the polygonal 
cube used to make the door) and subdivision surfaces. Each has it’s own purposes and behavior, 
as you will learn later. 

2 The name nurbSphere1 displays in a vertical box called the Channel Box located at the right 
of the workspace. Click the name and type a new name, Knob. 

We recommend renaming objects to keep your scene organized. (You will learn more about the 
Channel Box in the following steps.)

3 Click the cube to select it and rename it Door in the Channel Box.

4 In the side view, select the sphere (Knob) and choose View > Frame Selection to quickly 
zoom your view. 

The letter “f” displays next to the menu item to indicate the equivalent keyboard shortcut, called 
a hotkey. 

5 Click the Scale tool and scale the sphere inward along the Z axis to about half its original 
width. 

Move tool handles

Create NURBS Sphere
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This approximates the shape of a classic doorknob. (Leave all other scaling the same—you will 
scale down the entire Knob later.) 

Using the Channel Box and Outliner
Follow the steps to create another NURBS primitive object and learn about the Channel Box and 
the Outliner. 

Add a doorknob base

1 Select Create > NURBS Primitives > Cylinder. 

2 Rename nurbsCylinder1 to Base.

3 In the Channel Box (the panel at the right side of the workspace), type 90 in the Rotate X 
box and press Enter. This rotates the cylinder 90 degrees so it is pointed in the right direction 
for the knob.

You have just adjusted one of the object’s attributes. When you model, animate, render, and 
perform any kind of object manipulation, you change attribute values. 

The Channel Box only displays keyable attributes for which you can set animation keyframes. 
Sometimes, these keyable attributes are called channels.

4 In the side view, scale down Base from the center handle until it fits within the edges of 
Knob. This is roughly the proportion of a doorknob base. 

5 Move Base to the right, keeping a small portion of it within the edge of the sphere. 
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Improving the object’s display in the views
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6 To complete the doorknob, select Window > Outliner to parent Base to Knob. 

Parenting means a single object controls the attributes of one or several other objects, known as 
children. The Outliner shows all objects in your scene and displays the parent-child relationships. 
You use it mostly to organize your scene and select objects that may be difficult to select in the 
view. 

7 In the Outliner, MMB-drag Base onto Knob. Knob becomes the parent of Base. By parenting 
these objects, you can transform both objects as one unit.

Improving the object’s display in the views
The following steps show you how to quickly improve the object’s display in the view. 

Refine the doorknob’s display

1 In the perspective view, select Shading > Smooth Shade All. 

This shading mode is useful when you want to see the surface of your objects. Wireframe is the 
default display mode because smooth shading can slightly slow down the interaction speed. 

Tip

For extra practice, try selecting items in the Outliner using Shift-click for contiguous items and 
Ctrl-click for non-contiguous items. 
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2 Select Door and choose Display > Hide > Hide Selection to hide the door and focus on the 
doorknob. 

In this scene, the door is a minor distraction. As you create more complex scenes, hiding some 
objects is a convenient way to control clutter and focus on one task at a time.

3 Select Knob and choose Display > NURBS Smoothness > Fine to display the knob with 
more precision. 

This operation works on a per-object basis and is useful when you want a closer approximation 
of how it will render. NURBS smoothness is for display purposes only; it does not affect rendering.

If you tumble the view to see the back of the doorknob, notice that the connection between Knob 
and Base is too blunt. You will correct this in the following steps. 

4 Select Base and click the heading makeNurbCylinder1 at the bottom of the Channel Box. 

5 Change Spans from 1 to 2 and press Enter.

By setting the Spans value higher, you increase the number of surface curves that make up the 
cylinder. You will find out why in the next few steps.

The most important point is that Maya lets you change these creation-related attributes. These 
attributes and others used in the object’s construction are called construction history. 

Selecting and transforming components
The following shows you how to use marking menus to quickly select an object’s components 
and transform them.

Create a realistic-looking doorknob

1 In the side view, right-click Base and select Control Vertex from the menu that displays. 

This menu is a marking menu, another Maya convention, used to quickly access actions and tools. 
The menu that displays depends on what object you select. In this case, the choices relate to the 
geometry options of a NURBS object’s components. 
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Components are the points and elements that tie everything together. For example, control 
vertices (or CVs) are points that control the shape of a NURBS curve, and vertices are points that 
connect to lines to create polygons. 

2 Drag a selection box (sometimes referred to as marquee or marquee-select) around the control 
vertices (CVs) located just inside the edge of Knob.

3 Scale out the CVs until the outer edges of Base reach the inside edge of Knob. Use the 
following example as a guideline. 

The perspective view displays a smoother transition between Base and Knob.

Part of the reason the transition is this smooth is because you changed the number of surface 
curves—you set Spans to 2 in the Channel Box. With more curves, you can make finer and 
smoother edits to the NURBS object. For best results, you should always add curves or other 
construction history changes before you transform an object’s individual components. 

4 To quit component display mode and return to object selection mode, right click on Base 
again and choose Select from the marking menu. 

Positioning objects
The following steps show you how to precisely position the doorknob into the door. 

Position the doorknob

1 Choose Display > Show > Show Last Hidden to see the door again. The Display > Show 
submenu is the counterpart to the Display > Hide menu. 

2 Select Knob. When you select Knob, Maya also selects Base because it is the child. 

3 Scale down Knob in all directions to an appropriate size compared with the door. The 
transformation applies to both Knob and Base because of the parent-child relationship. 

4 Move Knob forward, up, and to the edge of the door, as shown in the following image. You 
may want to keep a small portion of the doorknob base within the door’s surface so it looks 
like they’re connected. 
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Duplicating and instancing
In this section you learn about a common operation, duplication, and how to define what gets 
duplicated and how. 

Finish the door

1 Select Knob and choose Edit > Duplicate ❒ . A window opens displaying Maya’s duplication 
options. 

The settings in the Duplicate Options window, as well as most other option window settings in 
Maya, correspond to an object’s attributes which you can edit later on.

2 For this example, the default geometry type, Copy, should be turned off and Instance 
turned on.

Tip

Any changes you make in an option window apply to that menu selection from then on. You can 
return to the factory option settings by choosing Reset Settings from the Edit menu in the 
option window. 

Duplicate Options window
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When you create an instance, you do not create an actual copy of the selected object’s geometry. 
Instead, Maya re-displays the original geometry so that you can transform it separately. 

Instances use less system memory than actual copies. The only disadvantage is that you cannot 
change the instance’s components, such as CVs, to be different from the original. 

3 Click the Duplicate button in the option window. Maya creates a duplicate named Knob1. 

4 Select Knob1, change Rotate X to -180, and move it to the opposite side of Door. You now 
have two doorknobs—a complete door.

Working with pivots

Make the door swing open

Suppose you want the door to swing open as if on hinges. An easy way to do this is to move the 
point around which the whole door rotates. This point is called the pivot. In this section you learn 
about working with pivots. 

1 Shift-click Knob, Door, and Knob1 to select them all. 

2 Select Edit > Group from Maya’s main window to group together the objects you selected. 

Grouping is another way to apply transformations to a group of objects. All three objects are 
parented under one group, which means all transformations to the group apply to the children 
as well.

3 Rename group1 to DoorGroup.

4 Select DoorGroup (use the Outliner if you cannot select it) and press the Insert key to 
display the group’s pivot point. 

Pressing Insert lets you edit the position of the pivot—which is the point Maya uses as the basis 
for all transformations. 

5 In the front view, move the pivot point to the lower left corner of Door, as shown in the next 
image. 
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The left side of the door is the logical place for a hinge, so you need the pivot point’s Y axis to 
align with the left edge of the door. The alignment of the pivot point’s X axis doesn’t matter in 
this case, but it is aligned with the bottom edge of the door by default. 

6 Press Insert again to set the new pivot point position. 

7 Select the Rotate tool. 

8 In the perspective view, click the green Y axis handle (it turns yellow once selected) and 
drag left and right. The door and knobs appear to swing on a hinge as you rotate 
DoorGroup. 

Using editors to select nodes and adjust attributes
The final lesson introduces the Hypergraph, Attribute Editor, and the concept of nodes. 

Examine the scene

1 In any view panel, select Panels > Panel > Hypergraph. 

The Hypergraph is a general scene editor like the Outliner, only more powerful. Like all editors, 
you can open it as a separate window (from the Window menu), but sometimes it’s convenient 
to open it in a view panel. 

2 Dolly (Alt-LMB-MMB) and Track (Alt-MMB) until the Hypergraph resembles the following 
image.

Like the Outliner, the Hypergraph shows the hierarchy of the objects in your scene. In this case, 
the Hypergraph also indicates something else: a dotted line between Knob1 and Base shows that 
Knob1 is an instanced copy. 

Dotted line indicates
an instanced copy.
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3 Click DoorGroup and select Window > Attribute Editor to see the relationship between 
objects and attributes.

The Attribute Editor shows all the attributes related to the selected object. Use this editor to 
examine or change attributes directly, especially if they do not appear in the Channel Box (such 
as Shear, which slants an object). 

4 In the Hypergraph, click the Knob rectangle to select the object. The Attribute Editor displays 
Knob’s attributes. 

The Knob attributes display under various tabs. Each tab represents a node, which is a group of 
related attributes. 

The first tab, Knob, contains the attributes describing Knob’s transformation. It is a transform 
node.

5 In the Hypergraph, click the Up and Downstream Connections icon to see the relationship 
between Knob’s nodes. 

Each tab represents a node.
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The Hypershade displays a dependency graph. It shows the flow of data dependencies between 
different types of nodes. For instance, an arrow points from makeNurbSphere to KnobShape. 
This means information flows from the makeNurbSphere node, which contains the construction 
history used to create the sphere, to the KnobShape node, which contains the resulting 
mathematical description of Knob’s shape. 

Maya continually analyzes the dependency graph with every change you make to the scene, up 
through your final render. Using the Hypergraph, programmers and advanced users can 
examine and alter the dependency graph for more direct control. They can examine rendering-
related connections between shaders, materials, textures, and lights, or connect nodes, such as 
the rotation attributes of two orbiting spheres. 

There are not many connections in this simple scene. As you learn about rendering and 
animation, particularly character animation, you will see many more connections between nodes.

CONCLUSION

You just completed the first lesson which should at least get you comfortable with Maya’s 
interface. The next section of this lesson describes Maya’s UI in brief. It is a reference point for 
you to return to should you forget what certain windows are for, or for such things as what 
hotkeys to use for which operation.

Up and Downstream Connections icon.
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MAYA’S EMBEDDED LANGUAGE (MEL)
MEL (Maya’s Embedded Language) is a scripting language whose commands provide the 
foundation for Maya’s capabilities. MEL can be used at any time to create tools that streamline 
the use of Maya and buttons for frequently used commands. 

Creating a window with MEL
Many of the tools you create with MEL are window-based.

Display window commands

1 To display a window you need two commands; one to make the window and one to show it. 
In the Script Editor, type the following lines:

window;

showWindow;

2 Highlight the text and press Enter on the numeric keypad, or select Edit > Execute in the 
Script Editor. 

3 An empty window displays. Close this window.

Tip

Highlighting the commands before you execute them keeps them at the bottom of the Script 
Editor for easy editing. 
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Add flags to control commands

Every MEL command has flags to control what the command will do. Flags can be added to the 
window command to specify the size of the window and to give it a meaningful title. 

Edit the existing script to add the following flags to the window command and execute as you 
did above.

window -title "My Toolbox"

-width 200 -height 300;

showWindow;

A larger window called My Toolbox is created and displays on the screen. 

Add a button to the window

Many control items can be placed in a window—text fields, buttons, and sliders are some of the 
most common items. 

1 To add a button (or any other item) to a window, you first have to add a layout to the 
window. Edit the script as shown in the following:

window -title "My Toolbox"

-w 200 -h 300;

columnLayout;

button;

showWindow;

2 Execute the script as you did before. Notice the new button in the window.

Currently, the window does nothing. At this stage, flags are added to the button command to 
name it and make it do something, for this example, create a sphere.

3 To find the command to create a sphere, select Create > NURBS Primitives > Sphere, click 
in a view, and look at the top of the Script Editor (the gray area). 

4 Copy and paste the command into the bottom portion of the Script Editor, highlight it, and 
press Enter from the numerical keypad.
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Edit the script in the Script Editor as follows. This attaches the command to the sphere button:

window -title "My Toolbox"

-w 200 -h 300;

columnLayout;

button -label "sphere"

-command "sphere -p 0 0 0 -ax 0 1 0 -ssw 0 -esw 360 -r 1 -d 3\

-ut 0 -tol 0.01 -s 8 -nsp 4 -ch 1;objectMoveCommand;";

showWindow;

5 Press the sphere button from the My Toolbox window to place the NURBS sphere in the 
center of the view.

Add a button to create a light

1 To find the command to create a directional light, select Create > Lights > Directional 
Light. 

2 Copy and paste the command from the top of the Script Editor just after the last line of the 
script you just completed.

window -title "My Toolbox"

-w 320 -h 240;

columnLayout;

button -label "sphere"

-command "sphere -p 0 0 0 -ax 0 1 0 -ssw 0 -esw 360 -r 1 -d 3\

-ut 0 -tol 0.01 -s 8 -nsp 4 -ch 1;objectMoveCommand;";

button -label "light"

 -command "defaultDirectionalLight(1, 1,1,1, \"0\",\

0,0,0);rotate -a -45 90 0;";

Tip

If the command spans a line, as in the above (-command "sphere -p 0 0 0 -ax 0 1 0 -ssw 0 -esw 
360 -r 1 -d 3\), add a backslash at the end. This tells Maya to ignore the space and continue with 
the command on the next line.
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When this command is used as a command from a button, it must be modified slightly so that 
the quotation marks (“) are not misinterpreted. Quotation marks are used on either side of a 
string of text like the title of the window or the label of the button. Since the light command uses 
quotation marks around the strings in the command, a backslash (\) is in front of the quotation 
marks that are part of the command.

Add a button to Render the scene

When you render the scene, you will not get the command in the Script Editor unless you turn 
on Echo All Commands from the Edit menu.

Make sure it’s on and select Render > Render into New Window.

button -label "render"

 -command "RenderIntoNewWindow;";

The Script Editor displays a lot of lines. The one you want is Render into New Window. 
Generally, when a lot of commands result from a single menu selection, the one you need has a 
recognizable name. To test a command, just cut and paste it into the Command Line to execute it.

Run the entire scene

Execute the string as shown in the following: 

window -title "My Toolbox"

-w 320 -h 240;

columnLayout;

button -label "sphere"

-command "sphere -p 0 0 0 -ax 0 1 0 -ssw 0 -esw 360 -r 1 -d 3

-ut 0 -tol 0.01 -s 8 -nsp 4 -ch 1;objectMoveCommand;";

button -label "light"

 -command "defaultDirectionalLight(1, 1,1,1, \"0\",

0,0,0);rotate -a -45 90 0;";

button -label "render"

 -command "RenderIntoNewWindow;";

showWindow;

Now that all the commands have been pasted together, when you press the sphere button and 
the new light and render buttons in My Toolbox, a light is created, the sphere is rendered, and 
the scene displays in Render View.
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Try adding more flags to the buttons to further customize the look of the window. When 
satisfied with the script, save it to your scripts directory as a text file, and/or drag it onto your 
shelf for easy access. 

Helpful tips
• The command can be written across multiple lines. Place a semi-colon (;) at the end of each 

command so that Maya knows when it has come to the end. 

• The on-line MEL documentation can be used to see all of the commands and flags available 
for them as well as short forms of each flag.
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MAYA UI DEFINITIONS IN BRIEF

The items included in the following by no means cover all Maya’s user interface components. 
This lesson covers the basics—the tools and operations you are most likely to use during most of 
your Maya sessions.

The lessons in the tutorial set use many of the following editors, windows, operations, and tools, 
so if you need to refresh your memory, you can always return to this list for quick information.

MAYA’S MAIN WINDOW

The following items are common to every Maya session and display by default when you first 
open Maya.

Menu sets
Maya has four basic menu sets. When you select a menu set from the Status Line’s pull-down 
menu, the menus that display in the main menu bar contain the tools and actions specific to the 
type of operation you want to perform. These menu sets are:

Animation
Contains menus for setting keyframes, creating set driven key relationships, path animation and 
constraints. Skinning and IK skeleton creation menus as well as menus supporting Deformers are 
also part of this set.

Modeling
Contains menus for creating curves and surfaces as well as Polygon creation and editing tools.

Dynamics
Contains menus for Particles, Rigid and Soft Body creation and editing tools. The Effects menu 
contains many pre-made dynamics effects tools and examples of what you can do with Maya’s 
dynamics tools.

Rendering
Contains menus for creating lights and materials as well as texture application tools. The Paint 
Effects tool set menus are also located here. 

Common Menus
The first six menus from the left are common to all menu sets (File, Edit, Modify, Create, Display, 
and Window). When you select a different menu set, these six menus remain the same.

Mini Bar
The Mini Bar contains commonly used tools including Selection, Move (or translate), Rotate, 
Scale, the Show Manipulator Tool, and the Currently Active Tool. The associated hotkeys for 
these tools are, from left to right, QW E RTY.
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Status Line

Drag the cursor over the icons to display pop-up help which shows the names of the items. The 
Status Line icons are, from left to right:

• Menu sets

• Create a new scene

• Open a scene

• Save the current scene

• Show/hide the selection set icons

• Select by hierarchy and combinations

• Select by object type

• Select by component type

• Set the object selection mask (pull-down menu)

• Pick masks

• Lock/unlock current selection

• Snapping: Grid, Curve, Point, View Planes

• Make selected object live

• Input and Output operations lists

• Turn construction history on/off

• Render into a new Render View window

• IPR Render into a new Render View window

• Set the field entry mode (pull-down menu)

Layer Bar
To see the Layer Bar, select Display > UI Elements > Layer Bar and check it on.The Layer Bar 
provides layer creation and display buttons. Layers in Maya are a powerful method of 
organizing the display and collection of objects in your scene. Clicking the button at the far left of 
the Layer Bar creates a new layer.

Layers are mutually exclusive—an object can only exist in one layer at a time. RMB clicking on a 
layer in the Layer Bar displays a menu which lets you control the layer contents and display its 
characteristics. 

There are several ways to use Layers in Maya. Some artists find layers invaluable when 
compositing, for instance. When preparing to composite, they put all the background objects on 
one layer, the central object on its own layer, while the foreground objects reside on yet another 
layer.

Shelf
Maya’s Shelf is comprised of two sections—the Mini-Bar section at the left and the user-defined 
shelf, or tabbed command storage sections, at the right.
22 A TASTE OF MAYA  2001, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this 
tutorial, you have agreed to the terms and conditions which can be found in the tutorial’s 
installation executable available from www.aliaswavefront.com/tasteofmaya.



FUNDAMENTALS

Time Slider

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
Time Slider
The Time Slider buttons control playback, pause, rewind, and some keyframing operations. From 
the Time Slider, you can set the current frame as well as advance or retreat from the next 
keyframe on the selected object.

• LMB-drag to “scrub” the current time. 

• Shift + LMB-drag selects a region of time (highlighted in red) which can then be moved 
around the time slider—in effect, moving keyframes around as a group.

• RMB in the main region of the time slider to display a menu with a list of choices. For 
example, you can Cut and Paste a selected region of keyframes back into the Time Slider or 
onto a different object.

Range Slider 
The Range Slider contains extra options used to control animation attributes. You can establish 
the range of animation frames in the scene, and by growing or shrinking the range slider, you 
can focus on specific regions of your frames.

The buttons at the right side of the Range Slider let you select the current Character and turn 
Auto Keyframing on or off. Clicking the button at the far right displays the Animation Timeline 
and Playback Preferences window from which you can change default settings.

Command Line
MEL stands for Maya Embedded Language and is Maya’s built-in scripting language. The 
Command Line, located directly above the Help Line, is a single line where you can view and 
write MEL commands. 

The left side of the Command Line is a text field where you enter MEL commands. The right side 
displays the last printed line of MEL feedback visible in the Script Editor. 

The button at the far right opens the Script Editor. (See Maya's Embedded Language (MEL)... 
page 16 for information on how to create buttons, etc.).

In addition to editing and running MEL commands, you can use this editor to add MEL 
commands to the Shelf. For example, if you write a simple script that you use often, such as 
scaling certain objects in a scene to a specified value, add that script to the Shelf where you can 
click the icon to access it immediately. 
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Help Line
The Help Line, located at the bottom of the main window, is very useful for beginners. It 
displays information about tools and procedures as you work in Maya. 

When drag your mouse over areas of the interface, information describing the item displays in 
the Help Line. When working with a command or tool, the Help Line prompts you for the next 
expected action, or provides tips on using the current tool.

Channel Box
The Channel Box is located at the right of the main window. This is where you view and enter 
information about nodes and the attributes for these nodes. If you make it part of your view, 
(which it is by default), you can quickly adjust attributes and instantly view the results. To close 
the Channel Box, select Display > UI Elements > Layer Bar and check it off.

The top section of the Channel Box contains basic information about the selected object. These 
are the attributes that control where the object is located in the scene. The other nodes related to 
this object are located directly under this section. 

The Shape nodes carry information about an object beyond its position, rotation and scale. For 
example, the makeNurbCube shape node contains information about width, length to height 
ratio, and Patches in U and V directions. These attributes are editable and keyframable. 

Also listed in the Channel Box are the input and output nodes related to the selected object.

Some attributes in the Channel Box contain preset pull-down menus from which you choose a 
setting. If you are not sure, LMB on an attribute to see if it contains a pull-down menu.

Cameras (views)
Viewing your scene in 3D is made easy in Maya using the camera views. The hotkey and mouse 
interaction for camera manipulation in Maya is widely regarded as the best in the industry. By 
default, a new scene in Maya contains four cameras, or views,—a perspective camera and 3 
orthogonal cameras.

Perspective Camera
The perspective camera mimics the way a film or television camera operates. This is the only 
camera in which you can tumble the view (Alt-LMB).

Orthogonal Cameras
Top, side, and front orthogonal cameras are provided by default. These cameras display the 
scene without a vanishing line of sight, or perspective view. They are used to accurately position 
objects in relation to world space and the grid used to measure distances.

Tips 

• In the Channel Box and Attribute Editor, RMB over attributes to access a drop-down 
menu specific to that attribute

• To edit multiple values, Shift-select and type a value to repeat this number for other 
items. For example, if you want to position an object in the center of the view, Shift-
select the Translate X, Y, and Z attributes, type 0,and press Enter.
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Panels
Once you become more familiar with Maya, there may be times when having extra windows or 
editors open can become a nuisance. Select the Panels > Panel menu in a view and select the 
type of window or editor you want to place in that view. See the following example:

To return to a camera view, select a menu item from the Panels menu in each view.

Hotbox
By pressing and holding down the space bar you open the Hotbox. The Hotbox is a centralized 
heads-up display for all the menus in Maya which contains marking menus and zones of 
interaction that can greatly increase your productivity.

The Hotbox can take a while to get used to, but it can also unlock a great amount of screen space 
by removing the need for the main menus.

EDITORS AND WINDOWS

You can use adjust attributes in Maya, change tool properties and save them, and interactively 
view the results of those changes and adjustments. In order to do this efficiently, most of Maya’s 
editors and windows correspond to each other. For example, no matter what the items are 
(lights, special effects, objects, polygons, etc...) you open its associated Attribute Editor, change 
the default settings, and watch the results in the views. The following describes the windows and 
editors most used during a typical Maya session.

Outliner

Perspective View

Render View Texture View

Channel Box 
(displays by default)
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Attribute Editor
The Attribute Editor is a more detailed version of the Channel Box. Where the Channel Box is an 
abbreviated list of keyable attributes, the Attribute Editor lists all attributes on the selected node 
or object. 

The Attribute Editor includes such items as sliders, pull-down menus, and drag-and-drop 
functionality. The tabs located at the top of the Attribute Editor let you choose which node to 
edit. The items displayed in the body of the Attribute Editor are the attributes associated with 
that node.

Transform node
Objects in Maya have a top level node called a Transform node. This basic node is used to control 
an object’s position, rotation, and scale. These attributes are known as the Transform Attributes.

Shape node
Objects have a secondary node, a Shape node, which contains information about an object’s 
surface history, render properties, and display quality.

Other nodes 
Other nodes, such as texture and material nodes, are best edited using the Attribute Editor in 
conjunction with the Hypershade/Visor.

CUSTOMIZING MAYA’S UI
In the Window > Settings/Preferences menu, various items open editors where you can set the 
commands that you use most often and save them to make your Maya experience truly your 
own.

Included in this menu are editors to assign hotkeys, change default display colors, re-arrange 
view panels, and many more.

Preferences window
Maya’s preferences are broken up into several areas. Interface, Display, Settings, and Modules. 
When you open the Preferences window (Window > Settings/Preferences > Preferences), you 
will notice the Categories at the left and the options at the right. Simply choose menu items, 
enter values, or turn items on or off to customize your Maya sessions.

For example, in the Interface Category, click to turn off In Separate Window for Open 
Attribute Editor so the Attribute Editor will not be floating when you press the Ctrl-a hotkey.

Interface/UI Elements
The Interface categories provide options to set how the UI behaves. You can also access these 
menus and options from the main menu bar. 
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Hotkeys
In addition to the hotkeys indicated beside menu items, Maya provides quick and easy ways to 
perform several operations you will use during each working session. 

These are default settings. If you want, you can re-assign these hotkeys in the Hotkeys Editor 
(Window > Settings/Preferences > Hotkeys).

Default hotkeys for cameras
Cameras and views in Maya are positioned and oriented by pressing the Alt key in conjunction 
with the LMB (Left Mouse Button) and MMB (Middle Mouse Button). See the following list:

• Orbit: Alt-LMB

• Zoom: Alt-LMB-RMB

• Pan: Alt-MMB

• Frame selected: press f

• Frame all: press a

Default hotkeys used to control the display in the views
In each of Maya’s views there are menus and hotkeys you can use to control display properties, 
such as shaded and wireframe modes:

• Press 1, 2, or 3 keys for lowest to highest resolution display smoothness on selected NURBS 
objects.

• Press 4 key for wireframe display

• Press 5 for shaded display no textures

• Press 6 for shaded display with textures

• Press 7 for shaded display with textures and lights

Default hotkeys for transformation tools and manipulators
These keys are the QWERTY keys on the keyboard. They have been chosen for these often-used 
operations because they are located in a comfortable position on the keyboard.

Move (translate)= w

Rotate= e

Scale=r

Select Tool=q

Special Tool manips=t

Learn to use these hotkeys to speed up your Maya sessions.

Tip 

When you first start to use Maya, tear off the Display > UI Elements menu and check items to 
see what you are turning on or off.
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Outliner
There are two methods to look at the contents of a Maya scene file: the Outliner and the 
Hypergraph. The Outliner displays the contents of your scene file in a listed format. The contents 
of the Outliner display as nested groups if the items under this group are part of a hierarchy. 

• to Re-order an object, MMB-click-drag (line between other objects).

• to Parent on object, MMB-click-drag (lines outline parent).

• to Expand/Collapse hierarchy, LMB on the + and - symbols.

• to Show Shape Nodes, RMB-click-select a menu item.

• to Select multiple continuous objects in a list, Shift-LMB-select the top object then the 
bottom object of list.

• to Select multiple non-continuous objects in list, Ctrl-LMB-select each object.

Hypergraph
The Hypergraph displays the contents of your scene in a window that shows the items in 
rectangles, and how they are connected by lines. The Hypergraph’s two modes of operation for 
looking at the contents of your scene are described in the following:

Scene Hierarchy mode 
This mode lets you see objects and their hierarchies much like the Outliner, but in a more 
freeform layout.

• to Re-order an object, LMB-click-drag (first select Options > Layout > Freeform Layout 
from the Hypergraph menus).

• to Parent an object, MMB click dragging one object on top of another object or group.

• to Expand/Collapse hierarchy, RMB-select Expand or Collapse from a menu.

• to Show Shape Nodes, by select Options > Display > Shape Nodes in the Hypergraph 
Options menu.

• to Select multiple contiguous objects, LMB-marquee a box around the objects.

• to Select multiple non-contiguous objects, Shift-LMB-select each object.

Upstream and Downstream Connections mode
This mode lets you see how the flow of information is moving from one node to another through 
connected attributes. This is similar to a production line where each piece of information travels 
between nodes, each with the specific task it performs on the information before passing it along 
to the next node in the stream.
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Hypershade / Visor
The Hypershade and Visor windows are used to build and manage textures and materials for 
establishing the rendered look of your scene. Although these are listed as separate UI elements, 
they are most often used together and appear as a single UI component.

Hypershade
The Hypershade portion of the Hypershade/Visor shares similar functionality to the 
Hypergraph. It displays materials and textures much like the Hypergraph displays nodes and 
attribute connections. 

Visor
The Visor is the portion of the Hypershade/Visor combination where you find scene elements in 
your scene, or may want to bring into your scene, to help create the look of objects when they are 
rendered. Lights, Cameras, Textures, Sourceimages, and Materials are found in the Visor. 
You can also use the Visor to navigate the hard drive to find and load other elements and scenes 
not associated with the current project.

Render Globals
General rendering settings are set in the Render Globals window. From the Render Globals 
window you can adjust settings for the rendered image size or resolution, Anti-aliasing quality, 
Raytracing quality, Motion blur, and IPR options among many others.

Render View
The Render View is where you test render your scene. The Render View window is also where 
you use IPR, Maya’s Interactive Photo-realistic Renderer. 

Graph Editor
The Graph Editor is where you manage the keyframe animation you have created. The Graph 
Editor displays keyframe animation as curves called animCurves. 
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