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Creating visually pleasing imagery and photo-realistic representations of 3D 
worlds is the ultimate goal of the rendering process. Maya’s rendering 
environment provides what sometimes may seem like an overwhelming amount 
of choices, and it may be difficult to get the look you want at first. That’s why 
Part 1 of this tutorial spells out the basics. Getting comfortable with Maya’s 
rendering interface is the first step. 

If you are familiar with Maya’s rendering interface, skip Part 1 and move onto 
Part 2 — Using Render View/IPR... page 13 .

• Maya’s Hypershade provides various options and methods with which you 
can interactively tweak the visual elements of your scene.

• Using Maya’s IPR (Interactive Photorealistic Rendering) and Render View 
provides instant feedback as you tweak scene elements such as texture 
placement, lighting, or special effects. 

In Part 1 of this tutorial:

• Rendering user interface... page 3 
• Creating a window layout for rendering... page 4 
• Previewing render results in Render View/IPR... page 6 
• Setting up to test render... page 7 
• Improving the Render View quality... page 8 
• IPR rendering... page 10 
• Tuning with IPR... page 11 
• Improving the IPR quality... page 12 



PART 1 — RENDER OVERVIEW

Accessing the scene files
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Accessing the scene files
To test what you will learn in this lesson, load pipeSystem.ma: This is the scene file you start 
with. It contains several layers of objects that compose a subterranean tunnel.

See Part 2 — Using Render View/IPR for more information about these layers and details about 
how to adjust the rendering aspects of the scene.

Before you start:

This tutorial requires Maya scene files. To download the tutorial files, please visit the 
Taste of Maya web site at www.aliaswavefront.com/tasteofmaya.

Starting Maya:

Double-click the Maya 3.0 Evaluation icon on the desktop, or from 
Start > Programs > Maya 3.0 Evaluation > Maya.

In Maya:

Once the tutorial files have been installed, set the current project to access the Maya 
scene files. To set the current project from within Maya:

• Select File > Project > Set and navigate to the directory where you installed the 
Maya scene files. 

• Select the directory Maya_tutorial_data and press OK.
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Rendering user interface

Hypershade/Visor Maya’s Hypershade/Visor provides access to 
every element (or node) in the scene. You can 
assign materials (sometimes called shaders) and 
textures to selected objects, or create and place 
lights and special effects in a scene simply by 
clicking their related swatches. 

Attribute Editor Hypershade provides direct access to the 
Attribute Editor for a selected node. From this 
powerful editor, you can change a node’s 
attributes by entering exact values and moving 
sliders. You can customize textures and colors 
as well as map special attributes to objects. 

Attribute Spreadsheet To change (most) multiple attributes for 
several nodes, use the Attribute Spreadsheet.

Camera Views If desired, you can interactively adjust the 
scene in the Camera Views (top, front, right, 
perspective).

Render View/ IPR Any adjustments you make can instantly 
display in both the views (displays hardware 
rendered results) and in the Render View/ 
IPR window (displays software rendered 
results).

Texture swatches

Material swatches

Utility swatches

Shading Group swatches

Hypershade panel 
and swatches

Visor Panel 
and folders

Hypershade menus Hypershade buttons
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Creating a window layout for rendering
Because you consistently access various windows when setting up a scene, it is strongly 
recommended that you create specific layouts to suit your needs. 

This sample layout displays the perspective view, Attribute Editor, Render View, and 
Hypershade/Visor all in one panel:

The following steps show you how to create this layout which works well with IPR and 
rendering in general. 

Customize the default UI

1 Select Window > Settings/preferences > Panels from the main menu bar.

2 In the Panels window, click the Layouts tab.

Tips 

• Try to avoid detached or floating windows that can get in the way and slow you 
down. 

• Once a layout is in place, you can quickly jump from one configuration to another by 
selecting a Shelf button or hotkey. See Customize the default UI next to find out how to 
create a Shelf button.

• Maya also provides pre-made layouts accessible from any view’s Panel menu 
(Panels > Saved Layouts).

Hypershade/Visor

Render View

Perspective View

Attribute Editor
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Selected Layouts tab in Panels window 

3 Press the New Layout button.

4 In the Name box, rename the new layout Hypershade/Render and press Enter to validate.

5 Press the Add to Shelf button.

6 Now select the Edit Layouts tab and choose 3 Pane Left Split from the Configuration pull-
down menu.

Edit Layouts tab selected in Panels window

Tip 

If you want to delete a shelf item, MMB-drag it to the trash can icon on the right side of the shelf 
bar.
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7 Select the Contents tab in the Edit Layouts section and set the following:

• Panel 1- Render View

• Panel 2 - Hypershade

• Panel 3 - Persp Panel

Now when you select the shelf button, the layout changes to this configuration. You may want to 
create several layouts using this method. 

8 Press Close.

Previewing render results in Render View/IPR
Preview render results by test rendering a scene in the Render View, or interactively change 
scene elements and test render using IPR.

Render View window
The Render View (Window > Rendering Editors > Render View) displays the rendered results 
of the scene. You can test render a single frame to see exactly what a batch or sequenced render 
might look like.

The Render View menu bar contains pull-down menus, which you can also access using the 
RMB while the cursor is in the window. Use the icons to quickly access the functions you most 
often use.

Render View icons
You can use the icons at the top left of the Status Line in the main window, 

or 

use the icons at the top of Render View to perform various operations. 

Tip 

Using the layout in the example, the Outliner can only be a floating window. If that limits your 
screen space, try using one of these methods:

• Create a hotkey that can raise and lower the Outliner. 

• Create layouts for Hypershade that replace the perspective view by the Outliner. 

• Create a layout that includes all four windows. 
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Setting up to test render
Hardware texturing (rendering in a modeling view) lets you see how textures, lights, and objects 
look before you preview the render in Render View. The following lists offers a typical 
procedure you can take to set up a scene before you render in Render View. 

To set up before previewing in Render View:

1 Click to make the perspective view active and select Shading > Smooth Shade All and 
Shading > Hardware Texturing from the view panel’s menu bar (or press 6).

2 Select Lighting > Use All Lights from the view’s menu bar.

3 Place lights in the scene. (The rendered result does not display in Render View unless there 
are lights in the scene.)

• To interactively adjust the lighting before you preview, use Maya’s transform tools in the 
view (Move, Scale, Rotate).

• To see an accurate preview result (even though it may take a little longer), adjust the 
Resolution and Anti-aliasing attributes in the Render Globals window. See Part 2 — 
Using Render View/IPR for details about setting these attributes.

To preview the render in Render View:

1 Click to focus in the view (or camera) you want to render.

2 From the Render View, select Render > Redo Previous Render, or click the 
Render into a new Render View window icon at the top-right of the main window’s Status 
Line.

3 If you want to render another view, select Render > Render in Render View and choose the 
view you want to render from the pull-down menu.

Tip 

If you are new to Maya, the best light to start with is the Directional Light 
(Create > Lights > Directional Light).

Remove 

Redo Previous 

Render 
Region

Display 
Real Size

Keep 
Image

Close IPR File 
and Stop Tuning

Display Alpha Channel

Display RGB Channels
Refresh the 

Redo 
Previous 
Render

IPR Image

IPR Render

Image

Show Render Diagnostics 

Grab Swatch 
to Hypershade/Visor

in the Script Editor
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The entire Render View window initializes and begin rendering in blocks.

4 Press the 1: 1 button to view the image at the Real Size, or actual resolution.

5 To render a region in Render View, marquee-drag (LMB-drag) a box around the part of the 
scene you want to render and select Render > Render Region.

Improving the Render View quality
The following shows a default rendered image in Render View. Notice the quality of the result. 
Sometimes this can happen when you zoom in (Alt-middle-left mouse button) to get a better 
view and do not select the 1:1 (Display Real Size) icon in Render View’s status line.

Tip 

Click the Redo Previous Render icon on Render View’s tool bar if you want to re-render the 
same view.

Note

If you scale the Render View window to a size other than the actual Render Globals resolution, 
the image may appear aliased or jagged.

Tip

Use Render Region when you test raytraced rendered effects and other rendering elements not 
viewable in IPR.

Image has jagged edges
and is not very clear.
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To improve the Render View quality:

When you’re ready to see an accurate result of the rendered scene:

1 Open the Global Attributes window (Window > Render Globals) and change the following 
settings to your liking. Remember—the higher the quality the slower the render time.

2 Press the Redo Previous Render icon in Render View.

Tips

• When you set Render Globals attributes, even if you zoom in or out, the results are 
still quite accurate. 

• If you place a Resolution Gate around the objects you want to render, only those 
results display in Render View.

Change Resolution Presets

Turn on
Maintain Width/Height Ratio

Set Presets to

Set Edge Anti-aliasing to High Quality or Highest Quality

Production Quality

Image is clear and
edges are smoother.
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IPR rendering
Rendering in IPR is very similar to rendering in Render View with one important difference. In 
addition to creating an IPR render file, IPR creates an image called a “Deep Raster” image, which 
contains more information than just the pixel color and matte information.

Deep Raster technology keeps track of the information that creates the pixel color, including 
lighting, shadows, and material definitions. When you adjust a related node, such as a light or 
material, only the value for that node is re-computed instead of the entire scene. This speeds up 
the rendering edit process and enables the “interactive” portion of IPR.

IPR advantages
Use IPR when you spend too much time testing and waiting for feedback. IPR improves on these 
and other time-consuming activities:

• Material attribute tweaking

• Texture placement, Color balancing, and filtering settings

• Lighting, including: 

• Placement

• Intensity and Fall-off

• Fog Density and Color

• Shadow Color and Intensity

• Light Glow and Lens Flare

• Reflection Map tweaking

• Shader to lighting and texture interactions

• 2D and 3D texture attribute tweaking

IPR limitations
For most tasks that involve repeated tweaking and rendering, IPR speeds up the process. 
However, there are some options that have not yet made it into IPR. 

• Raytraced shadows, refraction, and reflections do not display in IPR.

• Volumetric particle rendering attributes do not update in IPR, but surface shading can be 
adjusted and tuned on a stand-in geometric object.

• Displacement maps, Depth of Field, and 3D motion blur do not display in the IPR deep 
raster-based image.
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Tuning with IPR
After you establish the scene using the hardware rendered display for texture placement and 
rough lighting, use IPR as the next tuning tool. The following gives you a general idea of how to 
IPR render. Later on, you actually work with a Maya scene.

To tune the test render with IPR:

1 Position the perspective camera to frame the scene.

2 In Render View, select IPR > IPR Render > Current(persp).

The entire Render View initializes and begins rendering in blocks. This creates the deep raster 
image in the iprImages directory of the current Maya project. 

3 When the IPR render is done, Maya prompts you to select a region to begin tuning. 
Marquee-select a region to tune (LMB-drag-select).

The region you select updates. This portion of the deep raster is loaded into RAM and CACHED 
for quick system access. The size of the region you select determines how much system overhead 
is required.

4 In Hypershade/Visor, select the light or material you want to edit. The Attribute Editor 
updates to display the attributes associated with the selected item. Adjust these attributes 
while watching the IPR region update.

5 Select Render from the Render View window to test-render the image.

• Load only the object layers you edit to speed up the renderer. 

• Choose IPR tuning options selectively. For example, if you do not plan to work on 
shadows or special effects like glows, make sure to turn these options off. You can 
globally set and control options in the IPR section of the Render Globals window, or 
from the Render View’s IPR pull-down menu.

• Work at the lowest possible resolution that produces adequate feedback.

Important Note 

A deep raster image can be quite large. A typical image file size for a 720 x 486 (D1) resolution 
IPR image can be between 45 and 100meg. Make sure you have suitable disk space and real 
memory. If you have limited system resources, you may want to consider working with smaller 
resolutions.

Tip 

To stop a test render in Render View, press the Esc key at any time.
A TASTE OF MAYA 11 2001, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this 
tutorial, you have agreed to the terms and conditions which can be found in the tutorial’s 
installation executable available from www.aliaswavefront.com/tasteofmaya.



PART 1 — RENDER OVERVIEW

Improving the IPR quality

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
Rendered result at low resolution

Improving the IPR quality
You cannot use Display Real Size to zoom into the view or resize the Render View window 
when IPR rendering. If you do, the results are not good. 

To correct this:

1 Zoom in or out of the camera view for which you are performing an IPR render.

2 Select IPR Render Globals from the IPR menu in Render View. 

3 Set the attributes to give you the results you need. 

Not only can you set the attributes specific to IPR rendering (IPR Options), you can also adjust 
the Resolution and Anti-aliasing Quality for the scene.

CONCLUSION

Hopefully you feel a little more comfortable with Maya’s rendering workflow and are ready to 
move on to Part 2 where you will learn how to adjust several node attributes to get the rendered 
result you want.
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Using Maya’s IPR (Interactive Photorealistic Rendering) and Render View 
provides instant feedback as you tweak scene elements such as texture 
placement, lighting, or special effects. 

In Part 2 of this tutorial:

• IPR example... page 14 

• Render quality settings... page 16 

• Displaying accurate render results... page 16 

• Anti-aliasing... page 17 

• Render resolution... page 18 

• Render the finished view... page 23 
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Scene files
pipeSystem.ma: This is the scene file you start with. It contains several layers of objects that 
compose a subterranean tunnel.

Layers
The elements used to compose pipeSystem.ma have been organized into layers. 

• To display the layers, access the layer bar: Display > UI Elements > Layer Bar. 

• To turn the visibility of each layer on or off, press the RMB on the layer button and select 
Visible.

Layers in pipeSystem.ma

Tunnel layer: The base geometry for the tunnel system which was constructed from NURBS 
cylinders.

Pipes layer: The pipes that run through the tunnel.

Walkway layer: This layer is composed of instanced geometry which are objects that have been 
duplicated with the instancing option set to on. Instanced geometry lets you create a base object 
that, when duplicated, acts as a reference. Any edits made to this base object are mirrored in the 
instanced copies. The walkway was created using this method, using as few objects as possible.

Light layer: Contains the lights in the scene: point, directional, and spot lights. Lighting gives the 
objects volume and a sense of weight.

IPR example
This scene file uses a typical setup. Your goal is to maneuver the camera around the scene, frame 
interesting angles, then render them. The objects are textured and the lights are roughly set up. 
Feel free to experiment with the textures and lighting to create your own images.

Close-up of pipes and lights
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Wide view of pipes and tunnel

Open pipeSystem.ma scene file

1 Start Maya, then select File > Open Scene.

2 Select pipeSystem.ma.

3 Press Open. This file contains several objects and groups of objects:

• tunnelGroup

• pipesGroup

• lightsGroup

• walkwayGroup

• instancedWalkwayGroup

4 Open the Outliner to view these object groups, as well as lighting and camera objects.

5 In the Outliner, LMB on the + sign to the left of the object name to open the nested objects 
(these objects may also be parents of other objects).

The tunnel objects have been texture mapped. To see the textures in the views:

• Press 5 for shaded display.

• Press 6 for texture-shaded.

• Press 7 for textures with lighting in the perspective view. 
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Render quality settings
The pipeSystem.mb scene file renders at Preview Quality. When you test render this scene, 
notice various artifacts, such as edge-aliasing and low resolution light fog shadows. 

The pipeSystemFinish.mb scene file’s Render Global settings and light attributes are adjusted 
to create a high resolution image, called Production Quality. This file takes longer to test render 
because of the higher texture sampling and edge anti-aliasing settings.

Displaying accurate render results
Display the rendered image at a 1 to 1 display resolution by pressing the 1:1 button in Render 
View. 

Expand the Render View window:

1 LMB-click in the Render View window, then press the space bar to expand the window to 
full view.

2 Press the 1:1 button to scale the image to actual rendered resolution.

Note 

Because these textures are very dark, you may not see much in texture mode at this point.

Important 

If your system does not allow you to tumble the scene quickly, you should either restrict your 
viewing to wireframe, or hide some of the layers. When all layers are displayed in shaded 
modes, most systems without adequate graphics memory will not tumble freely.

Note 

If you view a rendered image at a scale other than 1 to 1, artifacts display. This can make an 
otherwise good looking image look aliased and chunky.
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OPTIMIZING THE RENDERED RESULT

Anti-aliasing
Before you begin tuning with IPR, you may want to review the Render Globals settings, the 
most important of which is the Anti-Aliasing level. 

Set the Anti-alias level

1 Select Window > Render Globals.

2 In the Anti-aliasing section of the Render Globals window, set Anti-Aliasing to Preview 
Quality. When close to testing the final result, turn the quality up to Production Quality. 

These settings are already adjusted in the pipeSystem.mb file. You can re-adjust them to suit 
your pace and the performance of your system.

Depth Map Fog Shadows
Fog Shadow Samples are located in the Shadows > Depth Map Shadows section of the 
Attribute Editor for the light casting shadows. 

Tip

Depth Map Fog Shadows can greatly increase rendering time.

Render View expanded
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Set Depth Map Shadows

1 In the Outliner, select each of the spot lights in the scene that cast depthmap shadows and 
have a light fog attached. You may need to RMB in the Outliner to turn on Show Shapes.

The following—domeLightShape, northSpotShape, and southSpotShape—are located under 
the lightingGroup node in the Outliner.

2 Adjust the Fog Shadow Samples attribute in the Attribute Editor to obtain a smooth look. 
When turned down to 15 or so, chunkier-looking fog shadows result, but the render time is 
faster. When ready for a finished render, turn this value up to about 70.

Render resolution
When rendering in Render View or IPR, its best to work at the smallest resolution yet maintain a 
clear enough view while working. In this scene file, the resolution is set to 720x486 or Digital 
Video CCIR601. Try the following to test render at other resolutions.

Test render at other resolutions

In Render View, select Options > Test Resolutions > 50% Globals. 

The test rendering resolution for Render View and IPR is now 1/2 the current pixel Resolution 
value set in the Render Globals window. This value is adequate when working with most items 
in the pipeSystem.mb scene.

Light Fog on northSpot

Note

• You can adjust the attributes for each light in its associated Attribute Editor. 

• If you select multiple objects at one time, their associated attributes display in the 
Attribute Editors one-by-one. To quickly edit most multiple selected items, use the 
Channel Box or the Attribute Spreadsheet
 (Window > General Editors > Attribute Spreadsheet).
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Tune the Light Fog for the northSpot light

An overhead shaft at the tunnels’ junction contains a spot light named domeLight. Light fog has 
been attached to this spotlight, plus it can cast depth map shadows.

The North and South tunnels also contain these same spotlights placed mid-tunnel (named 
northSpot, southSpot).

1 Select the northSpot object in the Outliner or Hypershade’s Visor.

2 Press f to frame the light. Pull the camera back to frame the spotlight with enough room to 
see the extent of the cone of light.

3 From the Layer Bar (Display > UI Elements > Layer Bar), hide the walkway layer. RMB the 
Layer button to turn visibility off.

4 Render an IPR image (Window > Rendering Editors > Render View > IPR Render > 
persp).

5 LMB drag a region to tune that includes some of the light fog.

6 In Hypershade/Visor, LMB-click the Lights folder icon to access its directory, then LMB-
select the northSpot icon if it is not already selected.

In the Attribute Editor, open the Light Fog section under Light Effects and adjust these 
attributes. Notice the IPR image updates in the Render View. 

You can also traverse the Light Fog attribute to the lightFog node by clicking the Connection 
Arrow Button at the right side of the attribute. 

7 Adjust the northSpot’s Intensity and the Dropoff to see how these attributes affect the light 
fog. 

8 Select the lightFog tab at the top of the Attribute Editor and adjust the Fog Color and 
Intensity. Watch the results in the Render View.

Close-up of pipe shading
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Tune the pipes shader

The pipes in this scene are shaded by the Blinn material. Blinn provides a realistic-looking 
metallic surface because it has specular highlight that you can control.

A texture is applied to provide bump and specular highlight. Since the Blinn material has been 
added, it can be considered a Shader.

1 Position the camera close to the central pipe so that you can see the effect of tuning the 
shader.

2 Hide the walkway and tunnel layers in the Layer Bar (Display > UI Elements > Layer Bar).

3 Render an IPR image.

4 LMB-drag a region to tune that includes pipes.

5 Select the metalBumpPipe material in Hypershade/Visor. To do this, in Visor’s Rendering 
section, LMB-click the Materials folder and:

• LMB-select the metalBumpPipe material.

• MMB-drag the metalBumpPipe material from Visor to the Hypershade panel.

Press the Show Up and DownStream Connections button at the top-right of 
Hypershade/Visor to display the nodes related to the shader you selected. 

6 In the Attribute Editor, begin adjusting the metalBumpPipe shader’s attributes.

• Adjust the Diffuse attribute.

• Notice the effect on the highlight when you change the Eccentricity attribute. Try 
changing the both the Specular Rolloff and Eccentricity.

• A 3D texture controls the Specular Color attribute.

7 In Hypershade, double-click the bump3d node and adjust the Bump Depth attribute in the 
Attribute Editor to display clearer, more defined bumps, or smoother, subtler bumps.

A 3D Brownian procedural texture is attached to the metalBumpPipe. 

This texture is connected to the Bump Mapping attribute as well as the Specular Color 
attribute. Using this simple trick, the Specular highlight follows the bump. 

When you adjust the metalPipeBrownian texture, you also adjust both bump and specular 
properties.
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Warning Light’s shader glow and corner light lens flare

Tune the Warning Light Glow

By applying a little incandescence and a little glow to a material, you can create glowing 
surfaces. The walkway safety lights and the windows on the vertical pipe have this glow.

1 In the Outliner, open the Pipes Group, and select the warningLight group.

2 Press f to frame the current selection in the camera view, then position the camera to frame 
the warning lights and part of the pipes.

3 From the Layer Bar (Display > UI Elements > Layer Bar), RMB the Layer button and turn 
the visibility off to hide the walkway and tunnel layers.

4 IPR render this view.

5 Select a tuning region around one of the warning lights.

6 Select the yellowWarningLight material, and:

• In Hypershade/Visor, LMB-click the Materials folder icon in the Rendering section of 
Visor.

• LMB-select the yellowWarningLight material.

• MMB-drag the yellowWarningLight material from Visor to the Hypershade panel.

7 Adjust the attributes on this Blinn material. and notice the updates in IPR, especially:

• the interaction between the Specular Color and Glow intensity

• the role Incandescence plays in the glow

All these attributes are all inter-related and require tweaking to find the right combination. Its 
hard to imagine trying to juggle these attribute settings without the interactive feedback IPR 
provides.
A TASTE OF MAYA 21 2001, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this 
tutorial, you have agreed to the terms and conditions which can be found in the tutorial’s 
installation executable available from www.aliaswavefront.com/tasteofmaya.



PART 2 — USING RENDER VIEW/IPR
Render resolution

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
Change the following and watch IPR update the changes:

• Try negative and positive values for the Eccentricity.

• Adjust the Glow Intensity (under the Special Effects section of the material’s Attribute 
Editor).

• Change the Color of the material.

Tune the Lens Flare on the corner PointLight

The blue corner safety light has an associated Lens Flare. Adjust these attributes while watching 
the IPR render results.

1 In the Outliner, select the cornerPointBlue light, and press f to center the camera’s center of 
interest on this object.

2 Position the camera back from this light to ensure the lens flare is caught by the camera.

3 Render an IPR image.

4 Adjust the attributes listed under the cornerPointBlueShape tab of the Attribute Editor.

5 The Light Glow attribute (in the Light Effects section) has a connected node called 
opticalFX1. Press the box at the right of the Light Glow attribute to access this node’s 
attributes.

6 The opticalFX1 node contains several attributes associated with Lens Flare, Halo, and Glow. 
Experiment with these values and watch the IPR results. 

Tune the Tunnel Highlight

1 In the Layer Bar, turn the visibility on for tunnel.

Using the same workflow, select and tune the tunnelWallBlinn material. This material is 
connected to the tunnel surfaces and contains more interesting texture and material applications.

To achieve the look of a bumpy slimy surface, several techniques are used for this shader. For 
instance, the way in which this surface treats specularity defines most of its appearance.

2 For the tunnelWallBlinn material, render in IPR, then adjust the specular attributes for 
Eccentricity and Specular Roll Off.

3 Adjust the Bump through several points:

• for the tunnelStencil node, adjust the Mask attribute 

• for the tunnelBump node, adjust the Bump Depth 

4 For the tunnelBrownian node, adjust the Specular Color from Color Balance > Color 
Gain.

Note 

Because the Halo Type pull-down menu is set to None, a halo effect does not display on this 
light and the attributes associated with Halo have no effect.
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IPR view of tunnel highlight, pipes and walkways hidden

Finished render of all elements 

Render the finished view
Now that you have tuned some of the scene, use Render into Render View to render the scene 
(check to see how the IPR edits stand up to the final render). 

• You may want to tweak the attributes in the Render Globals window to increase the 
Anti-aliasing level. 

• Turn the Fog Shadow Samples attributes on the lights that cast shadows back up to 
about 80 to produce smooth depth map fog shadows.

• You can also open the pipeSystemFinish.mb file which shows pre-adjusted Production 
Quality settings.
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Test rendering in Maya using two methods
In summation, both these methods have strengths and weaknesses, but together they provide 
accurate and fast feedback on the final look of the rendered scene.

• Render into Render View: Test-renders the selected camera regions after each tweak. When 
test-rendering a Ray Traced scene, use this method to see how reflections, raytraced 
shadows, and refractions display, and to test 3D motion blur.

• IPR: Renders an IPR deep raster file and provides fast interactive updates for each attribute 
or interactive adjustment. Use this method when tweaking materials, lights, depth map 
shadows, shader glow, lighting glows, and optical fx-like lens flare as well as 2D motion 
blur.

CONCLUSION

The fastest part of a renderer is how quickly you can make a decision about the scene. Regardless 
of the power available to perform the final render, waiting to see the results of a complex and 
interdependent shader or lighting setup can be frustrating. By viewing the adjustment in almost 
real-time, there are fewer test renders, especially when you are just getting started. This greatly 
increases a project’s turn-around and quality tests up-front.
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